Archive

Posts Tagged ‘KDE’

Google Gadgets en Linux y el dichoso error “js-script”

12 agosto 2009 Deja un comentario

Antes de nada, debo pedir disculpas por este largo periodo de ausencia. Entre unas cosas y otras nunca he encontrado momento para actualizar… pero ya estoy aqui de nuevo 😀

captura-google-gadgets

Hace algo así como una semana me entró la curiosidad de usar Kubuntu, ya que nunca le había dado una oportunidad a KDE y ahora que habia salido una nueva versión pues…me animé a probarlo :D. Al principio tuve mil y un problemas (los típicos de sonido, después Kopete me petaba SOLO cuando hablaba con mi novia…y cosas por el estilo) pero al final, de mejor o peor manera, fui solucionándolos todos.

Cuando ya lo tenía todo funcionando en condiciones, tocó el momento de poner bonito el escritorio y tal, lo cual no es muy difícil en KDE, ya que con Plasma puedes poner el escritorio como un mueble bar, pero la mayoría de los gadgets que podías poner o eran inútiles (he llegado a encontrar un gadget de plasma que es una barra con los programas favoritos de el personaje que lo creó) o con funcionalidad reducida (como por ejemplo KDETwitter), así que opté por Google Gadgets. (Google Gadgets puede obtenerse desde los repositorios de Ubuntu Jaunty en dos modalidades: GTK y Qt)

Después de instalarlo y ejecutarlo me aparece este error:

“Program can’t start because it failed to load the following module(s):

js-script-runtime”

Harto de buscar y no encontrar nada que me fuera útil (la gente que reportaba el error era casi en su totalidad usuarios de Fedora10 que se pasaron a la 11…) decidí bajarme las fuentes y compilarlo, a ver que pasaba.

Me puse a mirar por ahí, para ver las dependencias que requería compilar el programa en cuestión y me tropecé con esta página, donde aparecía la lista de dependecias necesarias para compilarlo:
– autoconf
– automake
– libtool
– SpiderMonkey
– libcurl
– libxml2
– zlib
– xulrunner-dev
– D-Bus
– Gstreamer

Después de instalar los “dev” de lo listado arriba me dió por comprobar si ahora funcionaba el Google Gadgets que instalé desde repositorios…y funcionó… Supongo que sería necesario SpiderMonkey para ejecutarse pero… esas dependencias se deberían resolver junto al “aptitude install google-gadgets-gtk” ¿no?… De cualquier modo, una cosa más solucionada 😀